Before you update to WHMCS 7.5!

All our modules are ready and updated for WHMCS 7.5 and backwards compatible till WHMCS 6.0.0.

Before you update to WHMCS 7.5 you must update all our modules first! The following WHMCS, PHP and Ioncube Loader versions are supported:

  • WHMCS 6.0.0 - 6.3.2 :: Valid for PHP 5.4 and 5.5 with Ioncube Loaders 5.1 or later
  • WHMCS 6.0.0 - 7.4.2 :: Valid for PHP 5.6 with Ioncube Loaders 5.1 or later and PHP 7.0 with Ioncube Loaders 6.1 or later
  • WHMCS 7.5.x :: Valid for PHP 5.6, 7.0, 7.1 and 7.2 with Ioncube Loaders 10.1 or later

Obtain the PHP and Ioncube Loader version in WHMCS

WHMCS 7.5 requires minimum PHP 5.6 with Ioncube Loaders 10.1.x or later! Check your settings in WHMCS » Utilities » System » PHP Info




Download the Modules for your PHP and Ioncube Loader version

If you met the WHMCS requirements, then you need to download the following Software:

  • For v3 Modules you need to download and update first the Core Addon Resellerclub Mods Console v1.5.0 - PHP 5.6, 7.0 and 7.1 and then all other v3 modules v3.13.0 - PHP 5.6, 7.0 and 7.1. The same for the Resellerclub FREE Tools, download and update the Addon RCLBT - FREE ResellerClub Tools v2.12.3 - PHP 5.6, 7.0 and 7.1
  • For v4 Modules you do not need to download and update anything manually. Just AutoUpdate the RCM Core Console v4 Addon and then all other v4 Modules with the AutoUpdate Wizard. The new Core Addon RCM Core Console v4.1.2 does check the requirements automatically and performs the update to the required releases for you.

I'm not ready for WHMCS 7.5, what should I do?

We highly recommend to update too even if you run WHMCS 7.4.2 or below. Download and update first the Core Addon Resellerclub Mods Console v1.5.0 and then all other v3 modules v3.13.0. The same for the Resellerclub FREE Tools, download and update the Addon RCLBT - FREE ResellerClub Tools v2.12.3. We offer different downloads based on your PHP and Ioncube Loader version. All downloads are available in the Products details page for your license, in TAB "Downloads"


I have bunch of modules and update is an arduous job with the v3 modules

We offer for customers with more than 3 modules a single zip file with all folders and files in the correct location and with a small guide to quickly update via cPanel or FTP! Drop in a ticket with the support department and provide the following exact details and we will be more than glad to provide you with the zipfile:

  • WHMCS version (eg. 7.4.2)
  • PHP Version (eg. 5.6.34)
  • Ioncube Loader Version (eg. 10.1.0)

Please be accurate when providing these details and do not only provide two digit version numbers (eg. PHP 5.6, WHMCS 7.2, Ioncube Loader 10.0)

  • 5 Users Found This Useful
Was this answer helpful?

Related Articles

Can I update my Trial Licence to any Licence type?

No, Trial Licences are unique for each customer and cannot be upgraded. If you like the product,...

Can I reissue a License?

Yes, any license but trial can be reissued for free without limitations. Login into our client...

How many times you make remote Licence validation checks?

Comercial mods makes each 3 days a remote validation check and free mods each 7 days. Once...

How can I cancel my leased licence?

Login into your client area and click the “My Products / Services” link from the client menu....

Can I update from a leased licence to an owned at any time?

[Obsolete] Yes you can! Raise a support ticket and we will make the necessary changes from leased...